PDA

View Full Version : Bent and Broken Push Rods in 392



Chung
08-18-2010, 02:34 PM
I had two bent and one broken pushrod in my 1700 loadstar dump truck. The engine is a v392, with a 4 bbl holley carb. The truck was backfiring through the carburetor when you would blip the throttle. I changed the accelerator pump (was bad) and power valve (was bad) and ended up pulling off one of the valve covers just to check. Found two bent rods on the right side, so I figured I better check the left. Found a broken rod there that I fished out with a magnet. I put in three new rods just to see if that was what was causing the backfire, and wahlah! No more backfire. Now, what caused the rods to bend and break, was it over revving of the engine?

mtnscouts
08-18-2010, 03:29 PM
Most likely over-rev.

ron3865
10-14-2010, 05:54 PM
I had two bent and one broken pushrod in my 1700 loadstar dump truck. The engine is a v392, with a 4 bbl holley carb. The truck was backfiring through the carburetor when you would blip the throttle. I changed the accelerator pump (was bad) and power valve (was bad) and ended up pulling off one of the valve covers just to check. Found two bent rods on the right side, so I figured I better check the left. Found a broken rod there that I fished out with a magnet. I put in three new rods just to see if that was what was causing the backfire, and wahlah! No more backfire. Now, what caused the rods to bend and break, was it over revving of the engine?

------------------------
That sounds exactly like the problem I have on a Loadstar1600 w/345(?). Would a couple of pushrods be easy enough to find?